Mineserver Community

Mineserver => Support => Topic started by: jamesl22 on May 07, 2011, 08:36:01 pm



Title: User not premium
Post by: jamesl22 on May 07, 2011, 08:36:01 pm
Hi,

When trying to login to mineserver I get a "User Not Premium" error. How can I fix this?

James


Title: Re: User not premium
Post by: thegk01 on May 07, 2011, 08:49:45 pm
Did you buy minecraft?  :D


Title: Re: User not premium
Post by: jamesl22 on May 07, 2011, 08:57:01 pm
I did. But several of my friends have not. Anyway, thats not the point. How do you ditch the error? I know its checking with minecraft.net. In the java server you have Online-mode = false but what in mineserver?


Title: Re: User not premium
Post by: Fador on May 07, 2011, 09:03:44 pm
We have this in the config.cfg:

# Validate usernames against minecraft.net?
system.user_validation = false;


Title: Re: User not premium
Post by: jamesl22 on May 07, 2011, 09:07:11 pm
Hi,

Thanks for the reply. I already have this in my config.cfg.

James


Title: Re: User not premium
Post by: thegk01 on May 07, 2011, 09:12:32 pm
 :o
Is there any error in the server console, too?


Title: Re: User not premium
Post by: jamesl22 on May 07, 2011, 09:15:09 pm
It says:

[20:09:47] Packets: Handshake: No validation required for player jms29
[20:09:48] sockets.cpp:98::client_callback(): Socket closed properly

But username is jamesl22 not jms29?? Something to do with character encoding parhaps?

BTW, server is linux running latest from git and client is windows running latest minecraft.


Title: Re: User not premium
Post by: thegk01 on May 07, 2011, 09:17:50 pm
Yes, this is a different problem (Notch changed from UTF-8 to UTF-16, see here: http://mineserver.be/forums/index.php?topic=408.0), but I had no problem to connect with the newest version. I don't think that these errors are connected at all.


Title: Re: User not premium
Post by: kiki64 on May 07, 2011, 09:19:00 pm
This commit might help your cause.  Not sure if it will help you or not but might be the fix.

https://github.com/MitchellMarx/mineserver/commit/d16606a2f6a7207776425dceb3e6f947aedff11c

You may want to try his fork to see if that will work for you as well.


Title: Re: User not premium
Post by: jamesl22 on May 07, 2011, 09:26:54 pm
Excellent, thats fixed it. Thanks.

Do you know if theres a fix for UTF-16 on its way?


Title: Re: User not premium
Post by: Rain on May 13, 2011, 09:01:18 am
Русский : Привет, выложите пожалуйста mineserver с исправленной ошибкой, связанной с "user not premium"
English : Hi , please submit mineserver the revised error associated with the "user not premium"


Title: Re: User not premium
Post by: thegk01 on May 14, 2011, 11:32:59 am
Русский : Привет, выложите пожалуйста mineserver с исправленной ошибкой, связанной с "user not premium"
English : Hi , please submit mineserver the revised error associated with the "user not premium"

I thought jamesl22 solved the problem?
And write here only in English, please ;) If everybody would write in his/her mother language here, we could close the forum because everybody is writing in other languages.

thegk01


Title: Re: User not premium
Post by: davidribeiro on May 26, 2011, 08:55:00 am
Is there a way to fix this on windows, where the commit is not an option? 

Thank you.


Title: Re: User not premium
Post by: Eclipse412 on August 28, 2011, 01:03:57 am
BUMP
Is there a fix for this? Tried the fix no help.