Mineserver Community

Mineserver => Development => Topic started by: Rain on November 03, 2011, 02:48:48 pm



Title: Problems building mineserver 2
Post by: Rain on November 03, 2011, 02:48:48 pm
How to build a minserver 2? An error at compile time the "old" way.

user@user-MS-7392 ~/Mineserver-mineserver2-99644ca $ cmake .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1123 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  CMakeLists.txt:59 (FIND_PACKAGE)


-- Target: mineserver
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_FILESYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /home/user/Mineserver-mineserver2-99644ca
   used as include directory in directory /home/user/Mineserver-mineserver2-99644ca/src
Boost_SIGNALS_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_SYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_THREAD_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca

-- Configuring incomplete, errors occurred!



Title: Re: Problems building mineserver 2
Post by: Kabekiz on November 04, 2011, 06:20:10 am
If you are like me your boost library is in an odd spot.

Look for this line...

Code:
FIND_PACKAGE(Boost COMPONENTS system filesystem signals thread REQUIRED)



and above it put this...

Code:
SET(CMAKE_INCLUDE_PATH ${CMAKE_INCLUDE_PATH} "/usr/src/boost_1_47_0/")
SET(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} "/usr/src/boost_1_47_0/stage/lib/")

FIND_PACKAGE(Boost COMPONENTS system filesystem signals thread REQUIRED)

Obviously substituting the location of the boost directories in there in the set commands.


Title: Re: Problems building mineserver 2
Post by: Rain on November 04, 2011, 09:06:15 am
Added this
Code:
SET(CMAKE_INCLUDE_PATH ${CMAKE_INCLUDE_PATH} "/usr/src/boost_1_47_0/")
SET(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} "/usr/src/boost_1_47_0/libs")
in CMakeLists.txt
Log:
Code:
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1123 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.47.0

  Boost include path: /usr/src/boost_1_47_0

  The following Boost libraries could not be found:

          boost_system
          boost_filesystem
          boost_signals
          boost_thread

  No Boost libraries were found.  You may need to set Boost_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.
Call Stack (most recent call first):
  CMakeLists.txt:67 (FIND_PACKAGE)


-- Target: mineserver
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_FILESYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/mineserver
Boost_SIGNALS_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/mineserver
Boost_SYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/mineserver
Boost_THREAD_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/mineserver

-- Configuring incomplete, errors occurred!


UPD: problem has been solved