For$
<!-- begin site header -->
<div id=

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Rain

Pages: [1]
1
Development / Problems building mineserver 2
« on: November 03, 2011, 02:48:48 pm »
How to build a minserver 2? An error at compile time the "old" way.

user@user-MS-7392 ~/Mineserver-mineserver2-99644ca $ cmake .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1123 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  CMakeLists.txt:59 (FIND_PACKAGE)


-- Target: mineserver
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_FILESYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /home/user/Mineserver-mineserver2-99644ca
   used as include directory in directory /home/user/Mineserver-mineserver2-99644ca/src
Boost_SIGNALS_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_SYSTEM_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca
Boost_THREAD_LIBRARY (ADVANCED)
    linked by target "mineserver" in directory /home/user/Mineserver-mineserver2-99644ca

-- Configuring incomplete, errors occurred!


2
Support / Generator trees
« on: August 01, 2011, 05:43:42 pm »
Hello, I would like to ask why the trees are generated correctly, some have leaves, and some have gone, are the bare logs, how can I fix it?

PS
Sorry if that something is wrong, I do not know much English, used google translite

Pages: [1]