For$
<!-- begin site header -->
<div id=

Author Topic: Crafting Not Working  (Read 5619 times)

willyp

  • Newbie
  • *
  • Posts: 2
    • View Profile
Crafting Not Working
« on: March 08, 2011, 03:32:06 am »
Hi,

Just set up a mineserver install on an ubuntu box. All working really well, except I can't get crafting to work.

A block of wood will give a momentary flash of planks but they're gone to quick to click on.

Is there a plugin that needs installing? I've got no idea where I've gone wrong...

Ta, will.

Fador

  • Administrator
  • Full Member
  • *****
  • Posts: 126
    • View Profile
Re: Crafting Not Working
« Reply #1 on: March 08, 2011, 08:34:39 am »
sounds like the recipes would be in the wrong place =/ There should be a directory "recipes" in the bin/ dir, if it's not there, copy the directory from files/

momo462

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Crafting Not Working
« Reply #2 on: March 08, 2011, 12:35:54 pm »
i got the same problem since i updated mineserver.
The recipes are there but do not seems to be loaded. ( i run mineserver from the bin dir only changing the port number  in the config file )

Fador

  • Administrator
  • Full Member
  • *****
  • Posts: 126
    • View Profile
Re: Crafting Not Working
« Reply #3 on: March 08, 2011, 12:44:32 pm »
ok so cmake messes up the directories ;b

in configure.h I have:
#define CONFIG_DIR_SHARE "share/mineserver/"

and it's looking the "recipes/" dir from there.

you can change that to:
 #define CONFIG_DIR_SHARE ""
and do "make" again to fix it I think...

winex

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Crafting Not Working
« Reply #4 on: March 08, 2011, 12:53:08 pm »
that wasn't cmake - that was me, actually...

this directory hell is in the process of making it right...

momo462

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Crafting Not Working
« Reply #5 on: March 08, 2011, 03:03:42 pm »
you can change that to:
 #define CONFIG_DIR_SHARE ""
and do "make" again to fix it I think...


Thanks !

willyp

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Crafting Not Working
« Reply #6 on: March 08, 2011, 10:47:59 pm »
ok so cmake messes up the directories ;b

in configure.h I have:
#define CONFIG_DIR_SHARE "share/mineserver/"

and it's looking the "recipes/" dir from there.

you can change that to:
 #define CONFIG_DIR_SHARE ""
and do "make" again to fix it I think...


Lovely, thanks! Working fine now.

Next issue, furnaces light and the arrow fills up white but the end result doesn't appear.
Help would be greatly appreciated!