For$
<!-- begin site header -->
<div id=

Author Topic: (2 repeated errors) incorrect chunk | chunk failed (getLight)  (Read 4759 times)

Odium

  • Newbie
  • *
  • Posts: 19
    • View Profile
Hey guys :)

So we've been getting 'incorrect chunk' errors more frequently.
When a player spawns the server gives the following error and regenerates part of the map.
There are portions of the map being seemingly eaten by the server on an increasingly regular basis.

[Warning] Map: incorrect chunk (missing xPos or zPos) regenerating


Besides that, the following error tends to pop up whenever a user logs in, though we haven't as yet noticed any significant side effects, unless the 2 errors are somehow linked:

[Info] :765: Loading chunk failed (getLight)

Anyone else experience this, or know what's going on?

[EDIT]
Using 15-Mar-2011 release
« Last Edit: March 23, 2011, 08:55:43 am by Odium »

Faded

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: (2 repeated errors) incorrect chunk | chunk failed (getLight)
« Reply #1 on: March 23, 2011, 11:35:05 am »
Seem's like the client/user's interface is loading up faster
than the server can load.. Is is like, really huge chunks?

Odium

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: (2 repeated errors) incorrect chunk | chunk failed (getLight)
« Reply #2 on: March 23, 2011, 01:57:02 pm »
well a couple appeared to be quite large, however I suspect that may have been due to cave generation being turned on at that stage.

the last few haven't been overly large, large enough say to eat small buildings and 3 / 4 blocks of the ground beneath.

as for the getlight error it begins when the server first starts up and continues until a user joins att which point it stops, then at every join/leave it pops up once again.
« Last Edit: March 23, 2011, 03:38:24 pm by Odium »

thegk01

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: (2 repeated errors) incorrect chunk | chunk failed (getLight)
« Reply #3 on: April 17, 2011, 01:52:15 pm »
I have the same problem.
My chunk sizes vary between 1 and 5 megabytes.
I think it would be better to have one file, one chunk (or fewer files). I think that mineserver does'nt read them as fast as every user interface wants to have this chunks.

Sometimes, before a chunk is regenerating due "missing xPos or zPox", the blocks which I build disappear. Then, I can't chat, and the whole server is uncontrollable (I can't enter commands). After 1 or 2 minutes, it is all okay... And one chunk is replaced :(

Okay, I'll try to modificate the actual code to save it in other ways than the "normal" mineserver does.

Will report any success here.

thegk01
// A wild INCONSISTENCY appears!
//
//  --------------
// | >FIGHT  PkMn |
// |  ITEM   RUN  |
//  --------------
//
// deoxxa uses MACRO ATTACK!

from plugin.h