Fork me on GitHub
  February 18, 2018, 04:52:54 am
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Can't connect to local server  (Read 3774 times)
Casper3641
Newbie
*
Posts: 1


View Profile
« on: April 24, 2011, 11:24:09 pm »

Quote
2011-04-24 16:19:43 [Info] plugin.filelog: Logging to mineserver.log
2011-04-24 16:19:43 [Info] plugin.filelog: Logging chat to mineserver_chat.log
2011-04-24 16:19:43 [Info] Plugin: Loading: ./flatpermissions.dll
2011-04-24 16:19:43 [Info] plugin.flatpermissions: Loaded flatpermissions!
2011-04-24 16:19:43 [Info] Plugin: Loading: ./passiveMobs.dll
2011-04-24 16:19:43 [Info] plugin.passiveMobs: Loaded passiveMobs!
2011-04-24 16:19:43 [Info] map.cpp::Map::init(): World world
2011-04-24 16:19:43 [Info] mineserver.cpp::Mineserver::run(): Generating spawn area...
2011-04-24 16:19:44 [Info] mineserver.cpp::Mineserver::run(): Listening on:
2011-04-24 16:19:44 [Info] mineserver.cpp::Mineserver::run(): 192.168.1.145:25565
2011-04-24 16:19:44 [Info] mineserver.cpp::Mineserver::run(): 169.254.204.43:25565
2011-04-24 16:20:19 [Info] mineserver.cpp::Mineserver::free(): Shutting down...
2011-04-24 16:20:33 Packets: Handshake: No validation required for player
2011-04-24 16:20:33 sockets.cpp::client_callback(): Unknown action: 0xy

The client will tell me end of stream. Any ideas? Thanks for the help.
Logged
mv2112
Newbie
*
Posts: 3


View Profile
« Reply #1 on: April 25, 2011, 03:22:22 am »

The same thing is happening to me. Im guessing this is because of the recent update to 1.5_01.
Logged
Matt - Kerplunc
Newbie
*
Posts: 11


Founder of Kerplunc and MinecraftGSP


View Profile WWW
« Reply #2 on: April 25, 2011, 08:10:28 am »

Yup it's an issue with the official branch of Mineserver.
It's fixed it Louisdx's fork of Mineserver though. You can grab it from
https://github.com/louisdx/mineserver
Logged

mv2112
Newbie
*
Posts: 3


View Profile
« Reply #3 on: April 26, 2011, 12:12:15 am »

Yup it's an issue with the official branch of Mineserver.
It's fixed it Louisdx's fork of Mineserver though. You can grab it from
https://github.com/louisdx/mineserver

I just built it and when ever i run it i get this:
Loading Chunk Failed (spreadLight)
Logged
Matt - Kerplunc
Newbie
*
Posts: 11


Founder of Kerplunc and MinecraftGSP


View Profile WWW
« Reply #4 on: April 26, 2011, 01:57:12 am »

That's an issue with your world folder, i've got no idea what's up
Logged

mv2112
Newbie
*
Posts: 3


View Profile
« Reply #5 on: April 26, 2011, 04:59:09 am »

But the server is auto-generating the world folder...
Logged
Matt - Kerplunc
Newbie
*
Posts: 11


Founder of Kerplunc and MinecraftGSP


View Profile WWW
« Reply #6 on: April 26, 2011, 06:36:58 am »

Really? Then i have no idea at all.
Windows or Linux?
Logged

Odium
Newbie
*
Posts: 19


View Profile
« Reply #7 on: April 26, 2011, 11:31:25 am »

I haven't been able to build louisdx's fork. :\
(Win7 VS2010)
--------------
\mineserver\plugins\commands\commands.cpp(33): fatal error C1083: Cannot open include file: 'tr1/unordered_map': No such file or directory

mineserver\src\chunkmap.h(35): fatal error C1083: Cannot open include file: 'tr1/unordered_map': No such file or directory

mineserver\src\plugin.h(32): fatal error C1083: Cannot open include file: 'tr1/unordered_map': No such file or directory
--------------------------
« Last Edit: April 26, 2011, 05:52:37 pm by Odium » Logged
peku
Newbie
*
Posts: 1


View Profile
« Reply #8 on: April 26, 2011, 01:36:58 pm »

Yup it's an issue with the official branch of Mineserver.
It's fixed it Louisdx's fork of Mineserver though. You can grab it from
https://github.com/louisdx/mineserver

I just built it and when ever i run it i get this:
Loading Chunk Failed (spreadLight)

I get the same error message thousands of times with Louisdx's fork but the server still runs and I can connect and was able to cut down some wood and build a workbench but everytime I try to use the workbench I get kicked out with a message like "invalid packet id 110". Anyone know what that's about?

Server is running Linux (Ubuntu) and client is Windows 7.
Logged
Odium
Newbie
*
Posts: 19


View Profile
« Reply #9 on: April 26, 2011, 05:54:07 pm »

Quote
I get the same error message thousands of times with Louisdx's fork but the server still runs and I can connect
my attempt at a build doesn't even produce anything that I can run. :\
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!