Fork me on GitHub
  November 15, 2018, 04:23:41 am
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Tested 2-Mar-11 Release: One BIG Problem!  (Read 5931 times)
thegk01
Newbie
*
Posts: 39



View Profile
« on: May 05, 2011, 10:58:41 am »

Hey guys!

I have built the new release; I noticed the fact that, as I logged in, the console said "tek1 logged in!" instead of "thegk01 logged in!". It seems that Notch changed the chat engine.
As I wanted to give me a bit TNT (because I'm working on TNT currently...), the console only received:
ietek1ttlP
give thegk01 tnt

I don't know how to fix it because I don't know the code of Minecraft... And nothing big changed on the chat.cpp file, or?

I hope this gonna be fixed... Until then, I try to program TNT Wink

-- thegk01


EDIT: And I needed to change the config.cfg that users are not looked up in the Minecraft user database - Sure, there is no "tek1"...
« Last Edit: May 05, 2011, 11:01:06 am by thegk01 » Logged

// A wild INCONSISTENCY appears!
//
//  --------------
// | >FIGHT  PkMn |
// |  ITEM   RUN  |
//  --------------
//
// deoxxa uses MACRO ATTACK!

from plugin.h
Ligustah
Newbie
*
Posts: 42


View Profile
« Reply #1 on: May 05, 2011, 01:59:18 pm »

Strings are UTF16 now, which means that each character has a length of two bytes.
I suppose Mineserver has not yet been completely updated to match this new string format.
Logged
ellisgl
Newbie
*
Posts: 6


View Profile
« Reply #2 on: May 07, 2011, 01:09:36 am »

DOH!
Logged
ellisgl
Newbie
*
Posts: 6


View Profile
« Reply #3 on: May 17, 2011, 03:15:31 am »

I think this has been fixed in a couple of the branches with changing string stuff to us std::wstring in the chat.cpp file. I can't test it at the moment.. =(
Logged
thegk01
Newbie
*
Posts: 39



View Profile
« Reply #4 on: May 17, 2011, 07:47:17 am »

In the "original" Mineserver chat.cpp, the strings are wstring! (afaik)...
Dunno how to fix this. :/
Logged

// A wild INCONSISTENCY appears!
//
//  --------------
// | >FIGHT  PkMn |
// |  ITEM   RUN  |
//  --------------
//
// deoxxa uses MACRO ATTACK!

from plugin.h
Ambobo25000
Newbie
*
Posts: 2


View Profile
« Reply #5 on: May 17, 2011, 08:09:46 pm »

I've got the same problem ! moo50 instead of Ambobo25000.

But I can't play too, I just spawn at impossible Y locations such as (-210349). I spawn under the world and keep falling until I die.

I'm new to Mineserver, I compiled the source on my Ubuntu PowerMac G4.
Logged
Ambobo25000
Newbie
*
Posts: 2


View Profile
« Reply #6 on: May 17, 2011, 08:23:07 pm »

Here is what I've written on github bug tracker :

Quote
Hello,
Mineserver is really great project !
I've just got an old PowerMac G4@1,25GHz to run a Minecraft server.
I've tried to run the official minecraft_server.jar which is heavy and takes over 95% of CPU usage. So I wanted to test Mineserver.

I've managed to build the git sources and launch Mineserver on powerpc / ubuntu. But when I connect, my username is troncated, "Ambobo25000" becomes "moo50", first issue.

Here is the console log :

mineserver.cpp:214::main(): Using config: ./config.cfg
mineserver.cpp:314::init(): system.path.data = "../files"
mineserver.cpp:314::init(): system.path.plugins = "."
mineserver.cpp:314::init(): system.path.home = "."
mineserver.cpp:314::init(): system.pid_file = "mineserver.pid"
[22:01:36] mineserver.cpp:357::init(): Welcome to Mineserver v0.1.15 (Alpha)
[22:01:36] Plugin: Loading: ./commands.so
[22:01:36] plugin.commands: Loaded commands!
[22:01:36] Plugin: Loading: ./filelog.so
[22:01:36] plugin.filelog: Loaded Filelog
[22:01:36] plugin.filelog: Logging to mineserver.log
[22:01:36] plugin.filelog: Logging chat to mineserver_chat.log
[22:01:36] Plugin: Loading: ./flatpermissions.so
[22:01:36] plugin.flatpermissions: Loaded flatpermissions!
[22:01:36] Plugin: Loading: ./passiveMobs.so
[22:01:36] plugin.passiveMobs: Loaded passiveMobs!
[22:01:36] map.cpp:256::init(): World world
[22:01:36] mineserver.cpp:529::run(): Generating spawn area...
[22:01:36] mineserver.cpp:564::run(): 11/121 done. 1ms per chunk
[22:01:36] mineserver.cpp:564::run(): 22/121 done. 3ms per chunk
[22:01:36] mineserver.cpp:564::run(): 33/121 done. 0ms per chunk
[22:01:36] mineserver.cpp:564::run(): 44/121 done. 2ms per chunk
[22:01:36] mineserver.cpp:564::run(): 55/121 done. 1ms per chunk
[22:01:36] mineserver.cpp:564::run(): 66/121 done. 2ms per chunk
[22:01:36] mineserver.cpp:564::run(): 77/121 done. 2ms per chunk
[22:01:36] mineserver.cpp:564::run(): 88/121 done. 1ms per chunk
[22:01:36] mineserver.cpp:564::run(): 99/121 done. 2ms per chunk
[22:01:36] mineserver.cpp:564::run(): 110/121 done. 1ms per chunk
[22:01:36] mineserver.cpp:564::run(): 121/121 done. 1ms per chunk
[22:01:36] Map: Spawn area ready!
[22:01:36] mineserver.cpp:636::run(): Listening on:
[22:01:42] Packets: Player 1 login v.11 : moo50

Ok, then the big issue is that my "moo50" player spawns in impossible location !
[22:01:42] map.cpp:711::getBlock(): Invalid y value (0, -2147483648, 0)
etc ... (keep falling and kill himself)

I tried to modify the spawn point with MCEdit but mineserver keep spawing me under my world !

I'm running mineserver on :
PowerMac G4@1,25GHz, 1.25Go RAM
ubuntu-server 11.04

And the client is running on MacBookPro MacOS 10.6.7
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!