For$
<!-- begin site header -->
<div id=

Author Topic: Error building latest Version on Debian  (Read 12896 times)

NemesisFS

  • Newbie
  • *
  • Posts: 2
    • View Profile
Error building latest Version on Debian
« on: July 23, 2011, 04:13:21 pm »
Hi
im trying to build the latest mineserver version and encounter this error:
Code: [Select]
> make all
Scanning dependencies of target mineserver
[  1%] Building CXX object CMakeFiles/mineserver.dir/src/lighting.cpp.o
In file included from /root/mineserver/src/user.h:39,
                 from /root/mineserver/src/chunkmap.h:41,
                 from /root/mineserver/src/lighting.h:33,
                 from /root/mineserver/src/lighting.cpp:28:
/usr/include/event.h:214: error: expected ';' before '*' token
/usr/include/event.h:215: error: expected ';' before '*' token
/usr/include/event.h:292: error: expected constructor, destructor, or type conversion before '*' token
make[2]: *** [CMakeFiles/mineserver.dir/src/lighting.cpp.o] Error 1
make[1]: *** [CMakeFiles/mineserver.dir/all] Error 2
make: *** [all] Error 2

i hope you can help me, i dont know how to fix that...

NemesisFS

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Error building latest Version on Debian
« Reply #1 on: July 23, 2011, 09:28:00 pm »
adding "#include <sys/types.h>" in user.h in line 39 fixed the problem.

while compiling i get a 2 warnings concerning the comparison between int and unsigned int in mineserver.cpp at line 922 and 927, but i guess thats not too bad.